2

Resolved

Unable to switch between views in Document Library

description

Hi Randy ! First of all, thank you for your amazing work, these really helped !
 
Unfortunately, i encountered an issue when changing a view in a document library. With your master page (_starter.master) i'm unable to switch between different views. Any idea ? Thanks in advance for your help !
 
Bastien

comments

bsimser wrote Oct 1, 2010 at 3:29 AM

Confirmed.
  1. Create a new site and apply the master page
  2. Go to the AllItems.aspx page of a document library or list
  3. Click Library under Library tools for the list
Expected behavior
Click on view drop down to show views

Actual behavior
Drop down is not functional

wrote Oct 1, 2010 at 3:29 AM

drisgill wrote Oct 6, 2010 at 7:46 PM

I'm looking into this, as of yet I haven't been able to reproduce in the latest version available for download, even by following your steps Bil.

Does the dropdown not work at all? Can you give me more specific steps to replicate, all lists and document libraries? Exactly which dropdown is failing?

Thanks

drisgill wrote Oct 7, 2010 at 3:32 PM

Ok, I have found that the issue doesn't show when I use an Enterprise Wiki but does if you have a Publishing Portal. I also have a fix, that I'll roll into a new release, for now you can fix your copy if you want. Add the following line to the hidden panel at the bottom:

<SharePoint:DelegateControl runat="server" ControlId="TreeViewAndDataSource"></SharePoint:DelegateControl>

Seems, counterintuitive but that delegate does something to the view dropdowns on Publishing sites.

drisgill wrote Oct 29, 2010 at 5:14 PM

I believe this has been fixed in the latest release, let me know if it hasn't been.

wrote Nov 10, 2010 at 10:26 PM

AussieGeekGirl wrote Mar 1, 2011 at 4:13 AM

hi Randy,

Thanks for this great start to my new master page.

I too experienced the same issue using the starter master page for a publishing site. I downloaded the starter.master on 18/1/2011.

I would be happy to send you my customised page if it would help and I have put a post on my blog (for my later reference). http://sharepointred.blogspot.com/


I am working on SharePoint 2010 Standard in a team site with the publishing enabled. I am working in IE8.

Happy to help further if I can.

thanks again
Max

wrote Feb 22, 2013 at 12:26 AM

wrote May 16, 2013 at 11:41 AM

wrote May 16, 2013 at 11:41 AM

wrote Jun 14, 2013 at 7:31 AM